Some events aren't being made available for querying immediately
Incident Report for Keen
Resolved
We've identified the issue as stemming from a bad piece of data in one of our queues. The data originated from a non-customer-facing internal process that has been shut down. We'll fix that process so it can't do that again.

In the meantime, we've removed that from blocking progress and everything looks normal now. We'll continue to monitor the situation but this should be resolved. Apologies for the inconvenience.
Posted Sep 22, 2014 - 14:41 PDT
Investigating
We've noticed an issue with a subset of our events not being immediately made available for querying. We're working on identifying the source of this slowdown. No data is lost. Thanks for your patience.
Posted Sep 22, 2014 - 14:18 PDT