Keen Website and Query API partial outage
Incident Report for Keen
Resolved
This incident has been resolved.
Posted Sep 22, 2022 - 08:02 PDT
Investigating
We are currently investigating this issue.
Posted Sep 22, 2022 - 07:29 PDT
This incident affected: Compute API, Datasets, Cached Queries, and Keen Website.