Slow Reads and Concurrency Limits
Incident Report for Keen
Resolved
The timed-out queries have all but vanished. This was likely a side-effect of decreased load on our systems. We are still looking into a real fix for the underlying issues, not all of which have been identified. We appreciate your patience, and apologize for any difficulty this may cause you.
Posted Oct 20, 2015 - 15:57 PDT
Investigating
Timeouts due to concurrency problems have returned. We are looking into it further. Sorry, and thank you for your patience.
Posted Oct 20, 2015 - 10:33 PDT
Monitoring
We are not encountering widespread concurrency limits anymore. We have some ideas of what the causes were but the investigation is still active.
Posted Oct 20, 2015 - 09:49 PDT
Investigating
We are encountering slower than normal queries in addition to some queries being timed out or rejected due to concurrency limits (too many queries running at once.) These problems are likely related and we are investigating the root cause.
Posted Oct 20, 2015 - 08:22 PDT
This incident affected: Compute API.