Event writes slow
Incident Report for Keen
Resolved
The backlog of events has been processed and all the things have returned to normal.

We experienced high latency in our write path which slowed inbound event processing to a crawl for a few hours. Inbound events were still accepted during this time, and we experienced no performance degradation as far as API event ingestion is concerned. Any queries executed during this timeframe were likely off by a small amount, but should all now be returning up-to-date totals.

We apologize for the inconvenience and wish you a pleasant start to your day.
Posted May 05, 2016 - 04:47 PDT
Identified
We've identified the issue and are working through the backlog of events. Things should be back to normal within an hour.
Posted May 05, 2016 - 03:58 PDT
Investigating
We are currently investigating issues with events being slow to write to our persistence layer. Users may not receive accurate data for events sent in the last hour.
Posted May 05, 2016 - 02:47 PDT
This incident affected: Stream API and Compute API.