System instability
Incident Report for Keen
Resolved
The DDoS attack appears to be resolved at this time. If another one comes through we'll set up a new notification.
Posted Feb 11, 2014 - 20:55 PST
Monitoring
We've checked with our provider and it appears they've been hit with a large DDoS that affected our cross data center replication. They added a null route for the offending IP(s) and stability has been restored.

We'll work with them to determine ways to prevent these issues from impacting our customers.
Posted Feb 11, 2014 - 20:39 PST
Investigating
We're seeing some degraded performance in our system right now. These may surface as API timeouts, both for writes and reads. Our engineering team is investigating.
Posted Feb 11, 2014 - 20:00 PST