Some query problems with newly added collections and event properties
Incident Report for Keen
Resolved
This issue has been resolved for all but a few customers with unique data sets. We're in the communication with each of them individually and is no longer a concern to new or other existing users.
Posted Jan 08, 2014 - 14:55 PST
Update
This problem is resolved for new projects and many old projects. There are about 100 very large projects remaining that are still affected. Due to the large amount of data processing required (Big Data!), it takes time to update these large projects. They are scheduled for update starting this weekend. To reiterate, this problem is only present for a small subset of customers when they add new properties or new collections to a project. They can still add new properties and new collections, and that data will be queryable by API. The issue is only presented when someone queries for schema (which is rare for most of our customers) or when they try to query using the workbench (which uses schema to populate dropdowns).
Posted Nov 27, 2013 - 13:30 PST
Update
We are still working on this! It's taking a while because we want to make sure schema calculations work long-term in a scalable way. We want to make sure it's done right and in a way that does not impact our users, so we've spent quite a bit of time determining the best way to proceed. We've got the plan now and we're executing on it. Thanks for your patience!
Posted Nov 22, 2013 - 19:25 PST
Identified
The query API is working fine for a majority of use cases, but we found a problem with the way we're handling brand new event collections and event properties (those added after 7am PST today). You can still query on these new collections & properties using the API. The only part that's not working is if you query for the schema of an event collection. The schema will be missing your new properties. Since the workbench uses schema queries to determine the properties available in the dropdowns, you might have issues using the workbench on new collections and new properties. We're currently working on this issue.
Posted Nov 21, 2013 - 13:56 PST
This incident affected: Stream API and Compute API.