Data not immediately queryable
Incident Report for Keen
Resolved
This issue has been resolved, and queries are fully up to date.

The root cause was a bug in the write path that processes add-ons. A customer had provided an invalid value for an add-on that was not being guarded against and that caused an exception. A fix has been deployed.
Posted Jun 25, 2014 - 13:38 PDT
Identified
We have identified an issue that is causing data to not immediately be queryable. Currently the delay is about 10 minutes. We expect to have this resolved shortly. No data has been lost.
Posted Jun 25, 2014 - 12:58 PDT