Slow query response
Incident Report for Keen
Resolved
We have resolved the issues affecting query performance and the analysis API should be back to normal!
Posted Nov 24, 2014 - 14:41 PST
Identified
We have identified several root causes (a combination of several unrelated but stacking issues) that have impacted query performance and are working towards resolution.
Posted Nov 24, 2014 - 14:16 PST
Investigating
Some analysis queries are taking longer than expected, we are investigating the issue now.
Posted Nov 24, 2014 - 09:20 PST
This incident affected: Compute API.