Extractions under load. Some queries with extraction analysis type timing out.
Incident Report for Keen
Resolved
We have made further enhancements to our extraction layer and reduced the number of extraction failures to a VERY small number. We will continue to work on making further improvements to our extraction layer and bring this number to 0.

Once again this only impacts the customers who run extraction queries, other features of the Keen API including Data Collection and Queries with other analysis types are healthy and serving traffic.
Posted Oct 20, 2016 - 11:27 PDT
Update
A small percentage of extraction queries continue to see errors but a majority of them are going through just fine. Please note this only impacts customers who run multiple simultaneous queries with the analysis type "extraction".

Other features of the Keen API including Data Collection and Queries with other analysis types are not affected. We are continuing to work on making improvements to our extraction query layer so that we can handle additional load and complexity.
Posted Oct 20, 2016 - 01:36 PDT
Monitoring
We have taken some steps to alleviate the load on extraction queries, most of the extraction queries are succeeding at this time. We will continue to investigate further and post updates. Thank you for your continued patience.
Posted Oct 19, 2016 - 20:37 PDT
Update
We are still investigating the root cause with extractions, we will post an update as soon as we have identified the root cause. Thank you for your patience.
Posted Oct 19, 2016 - 15:32 PDT
Investigating
Our extractions infrastructure is experiencing higher than normal load. We are currently investigating the root cause. In the mean time, some extraction queries may be timing out. All other query types are operating normally. Thanks for your patience.
Posted Oct 19, 2016 - 12:38 PDT
This incident affected: Compute API.