Service Downtime
Incident Report for Keen
Postmortem

You can find a detailed write up on our blog at https://keen.io/blog/56191254159/our-first-outage

Posted Jul 23, 2013 - 14:28 PDT

Resolved
Rolling service outage affecting multiple customers.
Posted Jul 18, 2013 - 19:42 PDT