Brief organization overview page distruption
Incident Report for Keen
Resolved
Usage stats are now restored.
Posted Mar 04, 2016 - 15:38 PST
Update
Organization overview pages have been restored, but usage stats are temporarily unavailable. We have identified the issue and are actively fixing right now.
Posted Mar 04, 2016 - 14:07 PST
Identified
We are experiencing a interruption in service for our Organization overview page on www.keen.io. We have identified the issue and are actively fixing right now.
Posted Mar 04, 2016 - 13:37 PST
This incident affected: Keen Website.