Quick Maintenance Will Cause Delays in Event Querying Availability
Incident Report for Keen
Postmortem

This was a bit of maintenance we performed due to some imbalance in the machines that handle our write load. For redundancy and availability we split this responsibility across many machines. Some recent backend instability had caused some of our machines to be handling an imbalanced amount of write load. This maintenance "rebalanced" the write responsibility and got things back where we like it.

This is a form of maintenance that is built in to Keen's infrastructure so the only impact was added latency for new events being available for querying.

Posted Feb 09, 2015 - 09:40 PST

Resolved
We've completed the maintenance and the small backlog created during this maintenance has been processed.
Posted Feb 09, 2015 - 09:28 PST
Monitoring
We're going to quickly perform some rebalancing of nodes in our write path that will cause events to become available for querying more slowly than normal. This is a controlled event and we do not expect a larger impact.
Posted Feb 09, 2015 - 08:54 PST