Query Durations are Up
Incident Report for Keen
Postmortem

It has been a tough couple of months for query performance at keen.io. In the spirit of transparency and providing more context, we've written a full update here: https://keen.io/blog/111360878761/query-performance-update Please take the time to read it to gain a better perspective on the performance issues that we have been having.

Posted Feb 18, 2015 - 09:42 PST

Resolved
Query durations are back to normal. We are continuing to monitor and are working on improving Query stability.
Posted Feb 17, 2015 - 17:41 PST
Investigating
We are investigating another incident with higher than usual query durations.
Posted Feb 17, 2015 - 17:27 PST
This incident affected: Compute API.