Inconsistent Query Results
Incident Report for Keen
Resolved
This issue is now resolved. Query results for the affected time period are back to their normal state. If you have any questions about this (or about anything else), as always, please don't hesitate to reach out to us via our standard support channels: https://keen.io/support/. Thanks again for your patience as we resolved this issue.
Posted Jun 12, 2016 - 13:35 PDT
Update
We are continuing to make solid progress towards a resolution and are being very careful with the data. We'll have another update on Monday. Thanks for your patience!
Posted Jun 10, 2016 - 18:50 PDT
Update
Good morning friends. Just wanted to let you know that we're still working towards a resolution. We made significant progress overnight and are continuing to push to get this resolved ASAP. We'll update you again as soon as we have additional information to share.
Posted Jun 10, 2016 - 08:00 PDT
Update
We continue to make progress towards a resolution. While we're working to complete the work as quickly as we can, we feel it best to report that we're still a ways away from wrapping things up. And while we can't give a precise ETA on when work will be complete, we'd like to set expectations as best we can given where we're at. It is possible data for the affected timeframe may be queryable sometime soon, but it is equally possible that it may not be back to a normal state until sometime tomorrow. The work we're doing to resolve this issue is both delicate and time consuming, and is such because we're double and triple checking every step we're taking to clean this up. Your trust in our ability to serve accurate results is paramount and is therefore not something we take lightly. It's vital that we get this right and we're taking all of the necessary steps so that we do so. We understand that this delay is less than ideal and apologize for the inconvenience. Please do not hesitate to reach out to us if you have any questions or concerns.
Posted Jun 09, 2016 - 19:15 PDT
Update
We are making solid progress towards a resolution, and are working to get all of your data queryable ASAP. Thanks for your patience!
Posted Jun 09, 2016 - 15:02 PDT
Identified
We've identified the source of the inconsistency and are currently working to return query results between 6/8 21:55 UTC to 6/9 00:04 UTC to their proper state. Results for queries outside that timeframe are unaffected by this issue. We expect this work to take a few hours or more, and will keep you updated as we get closer to resolution.
Posted Jun 09, 2016 - 11:49 PDT
Investigating
We are currently investigating an issue that is causing queries that include data from a few hours last night to respond with inconsistent results. The timeframe for the inconsistent data appears to be from 6/8 21:55 UTC to 6/9 00:04 UTC. We will continue to update you as we gain more information.
Posted Jun 09, 2016 - 08:56 PDT
This incident affected: Compute API.