System Incident
Incident Report for Keen
Resolved
We pinpointed the issue to be with the way we handle customers deleting events in a certain way. It uncovered a number of issues which we've patched, deployed, and are currently monitoring.

Our apologies for the inconvenience.

UPDATE: We've posted a post mortem on our blog here: https://keen.io/blog/66171746436/were-sorry-heres-what-happened
Posted Nov 04, 2013 - 15:56 PST
Monitoring
System has returned to normal for now. Investigating further into the root cause.
Posted Nov 04, 2013 - 12:56 PST
Investigating
We're investigating a large spike in connections that is currently causing errors for some of our users. We'll keep this updated as we find out more.
Posted Nov 04, 2013 - 12:34 PST