Slow Query Response Times
Incident Report for Keen
Resolved
Response times on the API have recovered and we are continuing to investigate.
Posted Jan 09, 2015 - 10:06 PST
Investigating
We're seeing high latency in query responses for some customers and are investigating the cause.
Posted Jan 09, 2015 - 08:40 PST