Slow queries
Incident Report for Keen
Resolved
This issue has been resolved. We are still investigating root cause.
Posted Mar 23, 2015 - 11:22 PDT
Investigating
We are currently experience slow query durations on our service. The team is actively investigating. Thanks for your patience.
Posted Mar 23, 2015 - 11:11 PDT