Data Center Maintenance Today
Incident Report for Keen
Resolved
This maintenance has been completed. There were no interruptions to service.
Posted Oct 02, 2014 - 08:36 PDT
Monitoring
Our hosting provider is planning maintenance today in all of their data centers. While we have prepared and expect no impact to our service, we will be monitoring our infrastructure throughout the day.
Posted Oct 01, 2014 - 07:51 PDT