Write backlog
Incident Report for Keen
Resolved
We've replayed the backlog and all events are now available for querying!
Posted Feb 27, 2015 - 11:00 PST
Update
The backlog is continuing to be worked. Looking good!
Posted Feb 27, 2015 - 10:32 PST
Monitoring
Our code change has completed and we are now replaying the backlog. All accepted writes will be written as we catch up.
Posted Feb 27, 2015 - 09:50 PST
Identified
Our planned maintenance of some components seems to have inserted some bad events that our write path refused to pass. As such we're deploying a code change to ignore these "poison" events and allow the backlog to be drained.
Posted Feb 27, 2015 - 09:42 PST
Update
We currently have a backlog of events to process. Writes to our API are delayed in processing. The team is working on the issue.
Posted Feb 27, 2015 - 09:03 PST
Monitoring
We are beginning planned maintenance on our write path that may result in a brief delay for events to be available for querying. This maintenance should take approximately 1 hour.
Posted Feb 27, 2015 - 08:22 PST