Poor Query Performance and Increased Timeouts
Incident Report for Keen
Resolved
We've completed isolating specific workloads that were causing problems and things are looking speedy again. We apologize for the unpredictable query performance today.
Posted Dec 07, 2014 - 20:18 PST
Investigating
We're investigating increased load.
Posted Dec 07, 2014 - 18:30 PST