Slow incoming event processing times
Incident Report for Keen
Resolved
This incident has been resolved.
Posted Apr 22, 2015 - 16:03 PDT
Update
There is currently a short delay between when your events are sent and when they available for querying. The delay is less than one hour and this issue will be resolved within the next 20min.
Posted Apr 22, 2015 - 15:39 PDT
Monitoring
There is currently a ~1hr delay between when your events are sent and when they available for querying, but we've addressed the root of the problem and we are quickly getting caught up on processing these backlogged events. Btw, did you know there is a chart on http://status.keen.io/ where you can monitor the queue depth? It should be back to normal in 20min or so.
Posted Apr 22, 2015 - 15:03 PDT
Update
There is currently a 1-2hr delay between when your events are sent and available for querying, and the backlog is increasing. We're adding resources to help chug through the backlog while investigating root cause.
Posted Apr 22, 2015 - 14:34 PDT
Update
There is currently a 1-2hr delay between when your events are sent and available for querying. We're working hard to close that gap!
Posted Apr 22, 2015 - 13:49 PDT
Investigating
We are currently looking into an issue where processing events is slower than usual. We will update this thread as we make progress.
Posted Apr 22, 2015 - 12:16 PDT
This incident affected: Stream API.