Event write delay
Incident Report for Keen
Postmortem

A change in hardware configuration resulted in a temporary outage of our write processing infrastructure. Restarting the write process fixed the issue, but it took longer than usual to do so due to a mistake in merging the latest code into the deployment branch.

Posted Sep 08, 2015 - 14:47 PDT

Resolved
Event writes are caught up now. Delays for event visibility in queries should be back to the normal ~10 seconds.
Posted Sep 08, 2015 - 14:45 PDT
Identified
We identified the cause of the delay and repaired the issue. The writing process is catching up now. Again, no data was lost.
Posted Sep 08, 2015 - 13:52 PDT
Investigating
We are investigating a delay in writing events. No data has been lost; this is only a delay in events being available in queries.
Posted Sep 08, 2015 - 13:27 PDT
This incident affected: Stream API.