Slow query responses
Incident Report for Keen
Postmortem

This incident had the same root cause as the earlier slowdown this afternoon (a number of organizations sending expensive queries concurrently). We are working on improving our ability to more rapidly detect and respond to this scenario.

Posted Jun 09, 2015 - 19:15 PDT

Resolved
This incident has been resolved.
Posted Jun 09, 2015 - 19:14 PDT
Identified
We are working to resolve a query slowdown similar to this afternoon's.
Posted Jun 09, 2015 - 19:00 PDT
This incident affected: Compute API.