Delay in Writing Events
Incident Report for Keen
Resolved
All is steady; events are ready for query within seconds of capture. Thanks for using Keen IO!
Posted Apr 14, 2015 - 14:48 PDT
Monitoring
Event writes have returned to normal. An increase in the number of inbound events caused a backlog to form in our ingestion pipeline leading to the delay. We are continuing to monitor the inbound event queue.
Posted Apr 14, 2015 - 13:57 PDT
Investigating
We're currently investigating a delay in events being written. Events are currently 1 to 2 minutes behind. Queries on most recent few minutes of data will be inaccurate until these events are written. This impacts all customers.
Posted Apr 14, 2015 - 13:15 PDT
This incident affected: Stream API and Compute API.