Occasional slow queries
Incident Report for Keen
Resolved
Our maintenance and observation has been completed. Both APIs appear stable and performing normally.
Posted Aug 08, 2016 - 18:15 PDT
Monitoring
Our read/write times have normalized. We are continuing to monitor while we perform some maintenance on our services. We do not expect any impact on API use during this maintenance.
Posted Aug 08, 2016 - 15:36 PDT
Investigating
Query durations appear to be getting slightly worse, and the collection API is also falling behind. We are actively investigating.
Posted Aug 08, 2016 - 13:36 PDT
Monitoring
We have been seeing occasional spikes in query latency since ~6am PDT today. We believe this is related to operational work in progress on our storage layer, which we had expected to be transparent. We will continue to monitor this closely while we work to get back to normal operation. We apologize for any inconvenience; thanks for your patience!
Posted Aug 08, 2016 - 12:10 PDT
This incident affected: Stream API and Compute API.