Query durations are high.
Incident Report for Keen
Resolved
We've made significant adjustments to our query execution this morning, increasing capacity by 30% and distributing query execution across multiple data centers. At present our query durations have leveled out and look much more consistent.
Posted Mar 03, 2015 - 08:40 PST
Update
We're continuing to make adjustments internally to improve queries. At present query durations are looking really great. We'll be leaving this incident open as we continue to work on improvements.
Posted Mar 03, 2015 - 07:57 PST
Monitoring
Query durations have returned to normal levels. We deployed some additional capacity and are now deploying some configuration changes that should improve things further. We expect that query durations will continue to be higher than normal as we continue to investigate
Posted Mar 03, 2015 - 07:26 PST
Investigating
We're investigated increased query duration.
Posted Mar 03, 2015 - 07:13 PST