Delays in writing events and slow queries
Incident Report for Keen
Postmortem

A back-end storage node was performing slowly. This triggered delays in writing events as well as slow query responses. Restarting the Cassandra service on the node brought it back to normal; some upstream services then had to be restarted as well to clear their state. Once these restarts were completed everything caught up quickly.

Posted Aug 30, 2015 - 11:26 PDT

Resolved
Both query times and write event delay are back to normal. We will continue monitoring.
Posted Aug 30, 2015 - 11:24 PDT
Identified
We have taken steps to fix the underlying cause of both write and query delays. Both appear to be recovering now.
Posted Aug 30, 2015 - 10:57 PDT
Investigating
We are currently experience slow queries and delayed writes. We are working to remedy this as quickly as possible. No data has been lost.
Posted Aug 30, 2015 - 10:48 PDT
This incident affected: Stream API and Compute API.