Write Delay
Incident Report for Keen IO
Resolved
We've just completed working through the backlog and all events should now be readable. We apologize again for any inconvenience this issue has caused.
Posted 8 months ago. Apr 25, 2017 - 12:10 PDT
Update
We're still working through the backlog and are hoping to be caught up soon. Thanks again for your patience.
Posted 8 months ago. Apr 25, 2017 - 11:31 PDT
Monitoring
We've deployed a fix and are now chewing through the backlog of events that piled up during the issue. It's going to take some time to work through the entire backlog which means it's going to be just a bit longer until all events are available for reading. We appreciate your patience and thank you for hanging in there with us as we address this issue.
Posted 8 months ago. Apr 25, 2017 - 10:22 PDT
Identified
We've identified a bottleneck in our writers and are currently working on mitigating the issue. Stay tuned.
Posted 8 months ago. Apr 25, 2017 - 10:13 PDT
Investigating
We're currently investigating a delay in writing events. No data that we acknowledge is lost, but newly published events are likely unavailable at this time. We'll share updates as they become available. Thank you for your patience.
Posted 8 months ago. Apr 25, 2017 - 09:52 PDT
This incident affected: Stream API and S3 Streaming.