Query instability
Incident Report for Keen
Resolved
The instability has been resolved. A writeup of the incident will follow. Thanks for your patience!
Posted Jun 12, 2014 - 18:20 PDT
Investigating
Some customers are experiencing timeouts for their queries. We're investigating and will update as we know more! Sorry for any inconvenience.
Posted Jun 12, 2014 - 13:58 PDT