Event write delay
Incident Report for Keen IO
Resolved
We've processed the backlog, and events should be available for querying. Sorry about the delay!
Posted 7 months ago. Jan 26, 2017 - 14:14 PST
Monitoring
The fix has been deployed and appears to be working. We are catching up on the backlog now, and are on pace to be back to normal in about an hour.
Posted 7 months ago. Jan 26, 2017 - 13:00 PST
Update
We have identified the root cause of the write event delay and are testing a fix now. We hope to have it deployed shortly, after which the delay should catch up within an hour or two. We will post again once we can confirm that the fix is working.
Posted 7 months ago. Jan 26, 2017 - 12:50 PST
Identified
There is a delay in events being written to our data store. We believe this is related to a code deployment at ~11:05 am PST, which we have rolled back, but we may need to clean up some of the events written in the interim before processing can continue. We will update once we know more details.
Posted 7 months ago. Jan 26, 2017 - 11:38 PST
This incident affected: Stream API.