Increase in Query Durations
Incident Report for Keen
Resolved
Query durations have returned to normal. The underlying cause was a failure in a portion of our query queues that caused an increased in latency and a premature failure of some outstanding read requests.

The affected services have been disabled and we'll use the metrics we accumulated to diagnose the failure before proceeding. We apologize for the inconvenience!
Posted Dec 30, 2014 - 14:44 PST
Monitoring
In testing a new query queueing system we've seeing increase durations of queries across the board. The change has been reverted and we are monitoring now to ensure that everything goes back to being nice and speedy!
Posted Dec 30, 2014 - 14:27 PST