503 errors on website
Incident Report for Keen IO
Resolved
The site has remained healthy for the past several hours.
Posted 20 days ago. Sep 27, 2017 - 16:13 PDT
Monitoring
We have increased the number of instances in our load balancer and are monitoring to ensure the problem is solved.
Posted 20 days ago. Sep 27, 2017 - 13:07 PDT
Investigating
We've received reports of 503 errors on keen.io. We are investigating and will update this incident as we work towards resolution.
Posted 20 days ago. Sep 27, 2017 - 12:39 PDT
This incident affected: Keen Website.