Event Writes are delayed. Some reads/writes timing out.
Incident Report for Keen
Resolved
All operations are back to normal. Thank you for your patience!
Posted Sep 22, 2016 - 13:18 PDT
Monitoring
We have made some adjustments to our infrastructure and are quickly progressing through our written events backlog. We will continue to monitor it's progress, and will leave this incident open until it is completely resolved.
Posted Sep 22, 2016 - 11:44 PDT
Update
Query performance appears to be back to normal. Event writes are still delayed, we are actively investigating.
Posted Sep 22, 2016 - 09:01 PDT
Investigating
We are investigating a slight delay at our storage layer. As a result, some event writes may return an error. All events that are accepted are being fully persisted, and no data is being lost, although there may be a delay before they are fully available to queries.

Some query requests may also be timing out, or rejected. We currently believe these two behaviors to be related to the same issue, and are actively investigating
Posted Sep 22, 2016 - 08:15 PDT
This incident affected: Stream API and Compute API.