Concurrency Failures
Incident Report for Keen
Resolved
Our failure rate has now recovered. The team is continuing to invent in improving performance and making sure that we are serving all valid queries.
Posted Oct 21, 2015 - 15:29 PDT
Monitoring
We are under less load and have largely recovered from our state of rejecting queries periodically. We still do not have a great idea of the root causes of this slowdown but have identified a couple of "levers" we can manipulate to address this in the short term, such as tomorrow during peak hours. This is an active investigation that is a priority for us this week.
Posted Oct 21, 2015 - 14:50 PDT
Investigating
We are encountering system slowdown which is resulting in an elevated number of queries being rejected. We are investigating the cause for the slowdown.
Posted Oct 21, 2015 - 08:22 PDT
This incident affected: Compute API.