API Performance Issues
Incident Report for Keen IO
Resolved
Our API looks like its held stable for the last hour or so. Our increased capacity should better handle these types of spikes in the future.
Posted about 1 year ago. Apr 06, 2017 - 18:32 PDT
Monitoring
We've deployed some changes to the load balancers and are seeing the error rate decrease back to its normal levels. We will continue to monitor.
Posted about 1 year ago. Apr 06, 2017 - 17:17 PDT
Identified
We've identified a bottleneck and are working to increase capacity. Thank you for your patience.
Posted about 1 year ago. Apr 06, 2017 - 16:56 PDT
Investigating
We are currently investigating performance issues with our streams and compute APIs. No data that we acknowledge as received is being lost.
Posted about 1 year ago. Apr 06, 2017 - 15:38 PDT
This incident affected: Stream API, Compute API, Datasets, and Cached Queries.