www.keen.io slow to load
Incident Report for Keen
Resolved
This incident has been resolved.
Posted Jul 18, 2016 - 12:30 PDT
Monitoring
We have been able to resolve the web performance issue and are continuing to monitor to make sure we don't see more performance issues.
Posted Jul 18, 2016 - 11:57 PDT
Update
The team is continuing to investigate the website performance issues. We have made some progress on isolating the issue, but we continue to work on this problem. Thanks for your patience.
Posted Jul 18, 2016 - 11:44 PDT
Investigating
We are currently seeing slow load times for our website. We have identified a performance issue in Mongo and we are actively investigating. Thanks for your patience!
Posted Jul 18, 2016 - 10:46 PDT
This incident affected: Keen Website.