Write event delay
Incident Report for Keen
Resolved
Write event delays are now at reasonable levels. We will continue to address the longer-term question of how to react to new bursts of load for the future. I guess this is a "victim of your own success" kind of problem, no? Thank you for your patience once more.
Posted Oct 02, 2015 - 11:48 PDT
Monitoring
Write latency is falling. The nature of write event delays will mean the status page will update more slowly than reality. We will continue to keep an eye (or two) on this.
Posted Oct 02, 2015 - 11:31 PDT
Identified
We've identified the issue: it seems to be related to a particular spike in load we encountered. We're allocating appropriate resources to compensate. Thank you for your patience.
Posted Oct 02, 2015 - 10:58 PDT
Investigating
We are experiencing a delay in writing events sent to us. We are investigating the root issue and will keep you updated.
Posted Oct 02, 2015 - 10:33 PDT
This incident affected: Stream API.