Delay in processing some events.
Incident Report for Keen
Resolved
We have deployed a fix for the issue and all backlogged events have now been processed. This problem began at around 7p central time and was cleared at around 8:50p central time.

Problem: Defensive code in our system blocked a larger-than-normal event and a configuration change had to be deployed to event processing systems. This took approximately 30 minutes to track down and another 30 minutes to configure and deploy. We're really sorry for the trouble!
Posted Nov 27, 2014 - 19:00 PST
Identified
We are experiencing a delay in process some events. We've identified the issue and are working on a fix. No events have been lost and all will be processed when the fix is completed.
Posted Nov 27, 2014 - 18:00 PST