Slow query durations
Incident Report for Keen
Resolved
Query performance is much more stable and we've identified further areas for improvement in the coming days. Thanks for your patience!
Posted Mar 25, 2015 - 17:06 PDT
Update
Query durations are still not to our satisfaction and we are continuing to focus on bringing them back down.
Posted Mar 25, 2015 - 15:08 PDT
Update
Query durations have started to improve, but are still slower than normal. We're continuing to investigate.
Posted Mar 25, 2015 - 13:24 PDT
Investigating
We are currently experiencing slow query durations on our service, we're investigating and will post an update shortly.
Posted Mar 25, 2015 - 11:17 PDT
This incident affected: Compute API.